sound recorder won't play and close automatically

Home Forums Tweak help sound recorder won't play and close automatically

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #857 Reply

    I want to play wav files with sndrec32.exe. A straight association brings up the program but I have to click the play button to run the particular wav file that I want to hear. What I want is for the program to run the file automatically so that when I run a wav file the sound will play without further intervention on my part and the program will close automatically after ward. I’ve tried editing the registry six ways from Sunday including inserting play -play /play close -close /close with combinations of %1 “%1”. Also tried creating my own brand new wav class referring to wavfile instead of soundrec which is the default. Still no go. The program comes up but it won’t run. It used to work in win98 but won’t work now in my win2k upgrade.

    Any ideas?

    This is the setting I use for my wavfile entry:









    @=”C:WINNTsystem32sndrec32.exe /play /close %1″

    The SoundRec entry (which I am not using because it won’t do what I want it to) is this:



    @=”Wave Sound”










    [HKEY_CLASSES_ROOTSoundRecprotocolStdFileEditing erb]

    [HKEY_CLASSES_ROOTSoundRecprotocolStdFileEditing erb<!–POST BOX–>]


    [HKEY_CLASSES_ROOTSoundRecprotocolStdFileEditing erb]


    The soundrec one is a little tricky and I am not sure how to edit it to add the /play /close components.

    Hope someone can help.


    #1502 Reply

    Instead of trying to update your filetypes through the registry, then I recommend using the tool provided by Microsoft to edit the filetypes.

    Think this quote will help you in the right direction:

    This is an easy fix, but there’re lots of steps so read closely. (You can cut&paste this into a .txt, or notepad, file

    if you want to print it out.)

    1. Open a windows explorer window (or “My Computer”) and pull-down the “Tools” menu from the top. Select “Folder Options” and choose the “File Types” tab from the top.

    2. Windows will read your file-associations and eventually give you a list. When the list appears, scroll down to the “WAV” entry (hint: press “w” and it will take you right there)

    3. Press the “Advance” button on the right. Select “Play” from the list of available actions. Press the “Edit” button on the right.

    4. In the field for “Application used to perform the action:” substitute what you find with, “sndrec32.exe /play /close %1”. Under the “DDE” information you’ll see a field entitled “Application” put “sndrec32” there and windows won’t try to overwrite what you’ve done.

    5. To select your own icon, go back to the “Edit File Type” window you were just on and you’ll see a “Choose Icon…” button. You can browse over to “windowssystem32sndrec32.exe” and find the old icons you might prefer.

    #1503 Reply

    Worked like a charm.

    Many thanks!

Viewing 3 posts - 1 through 3 (of 3 total)
Reply To: sound recorder won't play and close automatically
Your information:

<a href="" title="" rel="" target=""> <blockquote cite=""> <code> <pre class=""> <em> <strong> <del datetime="" cite=""> <ins datetime="" cite=""> <ul> <ol start=""> <li> <img src="" border="" alt="" height="" width="">

Comments are closed.