Missing WIndows Management Instrumentation Driver Extensions (Win2K)

Home Forums Tweak help Missing WIndows Management Instrumentation Driver Extensions (Win2K)

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #885 Reply
    Anonymous
    Inactive

    BITS service won’t run (Win2K SP4) because Windows Management Instrumentation Driver Extensions (WMIDE) is missing.

    The command ‘Net start BITS’ complains that ‘The dependency service does not exist or has been marked for deletion.’

    WMIDE is not in my list of services (Control Panel->Admininstrative Tools->Services).

    Any advice/hints would be greatly appreciated.

    #1582 Reply
    Snakefoot
    Member

    Found this newsgroup post from google groups which is very similar to your request:

    WMI Driver Extensions Service

    Though the solution is wrong, as Microsoft states that Win2k SP3+ requires WMI. More Info MS KB839089

    Then another guy with the same problem, but no solution about why the SP4 upgrade failed:

    windows2000 Problems after SP4 & Rollup installation

    I would recommend that you performed the install of Win2k using a CD with SP4 and the rollup package slipstreamed on the install cd.

    If you want to fiddle with getting the thing running, then you could try to add the service to the registry (Taken from a Win2k Pro SP4 installation):

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesWmi]

    “Description”=”Provides systems management information to and from drivers.”

    “DisplayName”=”Windows Management Instrumentation Driver Extensions”

    “ErrorControl”=dword:00000001

    “ImagePath”=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,

    74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,53,

    00,65,00,72,00,76,00,69,00,63,00,65,00,73,00,2e,00,65,00,78,00,65,00,00,00

    “ObjectName”=”LocalSystem”

    “Start”=dword:00000003

    “Type”=dword:00000020

    [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesWmiSecurity]

    “Security”=hex:01,00,14,80,b4,00,00,00,c0,00,00,00,14,00,00,00,34,00,00,00,02,

    00,20,00,01,00,00,00,02,80,18,00,ff,01,0f,00,01,01,00,00,00,00,00,01,00,00,

    00,00,20,02,00,00,02,00,80,00,05,00,00,00,00,03,18,00,8d,00,02,00,01,01,00,

    00,00,00,00,01,00,00,00,00,00,00,00,00,00,03,18,00,ff,01,0f,00,01,02,00,00,

    00,00,00,05,20,00,00,00,20,02,00,00,00,03,18,00,8f,00,02,00,01,02,00,00,00,

    00,00,05,20,00,00,00,23,02,00,00,00,03,18,00,9d,00,00,00,01,01,00,00,00,00,

    00,05,04,00,00,00,23,02,00,00,00,03,18,00,9d,00,00,00,01,02,00,00,00,00,00,

    05,20,00,00,00,21,02,00,00,01,01,00,00,00,00,00,05,12,00,00,00,01,01,00,00,

    00,00,00,05,12,00,00,00

    [HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesWmiEnum]

    “0”=”Root\LEGACY_WMI00″

    “Count”=dword:00000001

    “NextInstance”=dword:00000001

Viewing 2 posts - 1 through 2 (of 2 total)
Reply To: Missing WIndows Management Instrumentation Driver Extensions (Win2K)
Your information:





<a href="" title="" rel="" target=""> <blockquote cite=""> <code> <pre class=""> <em> <strong> <del datetime="" cite=""> <ins datetime="" cite=""> <ul> <ol start=""> <li> <img src="" border="" alt="" height="" width="">

Comments are closed.